re = /(.)(?:.*\1){1,3}/m
str = '2Q33K
KK238
JAJ29
K246K
KJKKK
3JKA9
3JKA9K8'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result