// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+98?)?{?(0?9[0-9]{9,9}}?)$").unwrap();
let string = "09036565656
09151251685
09337729292
09136565655
09125151515
+989151251685
+9809151251688
09124527844
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}