#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)(?<=[^\W\d_]{7})[^\W\d_]{1,3}\b"
Local $sString = "253. Ficam revogadas a Lei nº 1.711, de 28 de outubro de 1952, e respectiva legislação complementar, bem como as demais disposições em contrário." & @CRLF & _
"" & @CRLF & _
"foooooo" & @CRLF & _
"fooooooo" & @CRLF & _
"foooooooo" & @CRLF & _
"fooooooooo" & @CRLF & _
"foooooooooo" & @CRLF & _
"fooooooooooo"
Local $sSubst = "[\g<0>]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)