import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[^\\W\\d_]{7})[^\\W\\d_]{1,3}\\b";
final String string = "253. Ficam revogadas a Lei nº 1.711, de 28 de outubro de 1952, e respectiva legislação complementar, bem como as demais disposições em contrário.\n\n"
+ "foooooo\n"
+ "fooooooo\n"
+ "foooooooo\n"
+ "fooooooooo\n"
+ "foooooooooo\n"
+ "fooooooooooo";
final String subst = "[\\g<0>]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}