const regex = new RegExp('(?<=[^\\W\\d_]{7})[^\\W\\d_]{1,3}\\b', 'gmu')
const str = `253. Ficam revogadas a Lei nº 1.711, de 28 de outubro de 1952, e respectiva legislação complementar, bem como as demais disposições em contrário.
foooooo
fooooooo
foooooooo
fooooooooo
foooooooooo
fooooooooooo`;
const subst = `[\g<0>]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);