re = /(?<=[^\W\d_]{7})[^\W\d_]{1,3}\b/m
str = '253. Ficam revogadas a Lei nº 1.711, de 28 de outubro de 1952, e respectiva legislação complementar, bem como as demais disposições em contrário.
foooooo
fooooooo
foooooooo
fooooooooo
foooooooooo
fooooooooooo'
subst = '[\\g<0>]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result