package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[^\P{L}a-z]+(\.[^\P{L}a-z]+)+`)
var str = ` لــــیككاثو.لثو 普遍接受测试.世界 ya.ru домен.рф abcd.com شبكة.شبكة `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}