$re = '/[^\P{L}a-z]+(\.[^\P{L}a-z]+)+/ui';
$str = ' لــــیككاثو.لثو 普遍接受测试.世界 ya.ru домен.рф abcd.com شبكة.شبكة ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;