const regex = /[^\P{L}a-z]+(\.[^\P{L}a-z]+)+/uig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\P{L}a-z]+(\\.[^\\P{L}a-z]+)+', 'uig')
const str = ` لــــیككاثو.لثو 普遍接受测试.世界 ya.ru домен.рф abcd.com شبكة.شبكة `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);