$re = '/[0-9]\s*(?:[+-][+-]|\*/)\s*[0-9]/m';
$str = 'This is test 1 -- 1
This is test 2
This is test 3 + 1
This is test 4 */ 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);