# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d+\.\K\d+(?:,\d+)+/\r\n$0/gm;t' <<< "0.7,511,300
Lycthythtyjhos
4,465,688
Compusrteterterterve.World
3,827,911
Penthoutrtetet
1.2,148,123
Tripgtrgtrrtg
1,716,682
Dihtyhtyhtyh
01.1,115,456
Nov1995"