use strict;
my $str = '0.7,511,300
Lycthythtyjhos
4,465,688
Compusrteterterterve.World
3,827,911
Penthoutrtetet
1.2,148,123
Tripgtrgtrrtg
1,716,682
Dihtyhtyhtyh
01.1,115,456
Nov1995';
my $regex = qr/^\d+\.\K\d+(?:,\d+)+/mp;
my $subst = '\\r\\n$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";