import re
regex = re.compile(r"^\d+\.\K\d+(?:,\d+)+", flags=re.MULTILINE)
test_str = ("0.7,511,300\n"
"Lycthythtyjhos\n"
"4,465,688\n"
"Compusrteterterterve.World\n"
"3,827,911\n"
"Penthoutrtetet\n"
"1.2,148,123\n"
"Tripgtrgtrrtg\n"
"1,716,682\n"
"Dihtyhtyhtyh\n"
"01.1,115,456\n"
"Nov1995")
subst = "\\r\\n$0"
result = regex.sub(subst, test_str)
if result:
print(result)