$re = '/^\d+\.\K\d+(?:,\d+)+/m';
$str = '0.7,511,300
Lycthythtyjhos
4,465,688
Compusrteterterterve.World
3,827,911
Penthoutrtetet
1.2,148,123
Tripgtrgtrrtg
1,716,682
Dihtyhtyhtyh
01.1,115,456
Nov1995';
$subst = "\r\n$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;