#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=(Volume{))([\s\S]| |w\[0-9]| )+?(?=(\}))"
Local $sString = "\?\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\" & @CRLF & _
"\?\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\" & @CRLF & _
"\?\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\" & @CRLF & _
"\?\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\" & @CRLF & _
"\?\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\" & @CRLF & _
"\?\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\" & @CRLF & _
"\?\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\" & @CRLF & _
"\?\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\ "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")