import Foundation
let pattern = #"(?<=(Volume{))([\s\S]| |w\[0-9]| )+?(?=(\}))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\?\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\
\?\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\
\?\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\
\?\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\
\?\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)