# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=(Volume{))([\s\S]| |w\[0-9]| )+?(?=(\}))"
test_str = ("\\?\\Volume{edf560af-db87-11e3-80d2-806e6f6e6963}\\\n"
"\\?\\Volume{faadf429-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{faadf42d-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{faadf433-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{faadf439-db69-11e3-919f-e0db55bf0b1b}\\\n"
"\\?\\Volume{edf560b0-db87-11e3-80d2-806e6f6e6963}\\\n"
"\\?\\Volume{edf560b1-db87-11e3-80d2-806e6f6e6963}\\\n"
"\\?\\Volume{edf560b5-db87-11e3-80d2-806e6f6e6963}\\ ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.