#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:(\d+)\sYears?)?,?\s?(?:and\s)?(?:(\d+)\sMonths?)?,?\s?(?:and\s)?(?:(\d+)\sDays?)?$"
Local $sString = "3 Years, 1 Month, and 60 Days" & @CRLF & _
"2 Months, and 1 Day" & @CRLF & _
"3 Days" & @CRLF & _
"1 Month" & @CRLF & _
"5 Years, and 2 Months" & @CRLF & _
"7 Years, and 1 Day" & @CRLF & _
"1 Year, 1 Month, and 1 Day" & @CRLF & _
"700"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")