import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\d+)\\sYears?)?,?\\s?(?:and\\s)?(?:(\\d+)\\sMonths?)?,?\\s?(?:and\\s)?(?:(\\d+)\\sDays?)?$";
final String string = "3 Years, 1 Month, and 60 Days\n"
+ "2 Months, and 1 Day\n"
+ "3 Days\n"
+ "1 Month\n"
+ "5 Years, and 2 Months\n"
+ "7 Years, and 1 Day\n"
+ "1 Year, 1 Month, and 1 Day\n"
+ "700";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}