const regex = /^(?:(\d+)\sYears?)?,?\s?(?:and\s)?(?:(\d+)\sMonths?)?,?\s?(?:and\s)?(?:(\d+)\sDays?)?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\d+)\\sYears?)?,?\\s?(?:and\\s)?(?:(\\d+)\\sMonths?)?,?\\s?(?:and\\s)?(?:(\\d+)\\sDays?)?$', 'gmi')
const str = `3 Years, 1 Month, and 60 Days
2 Months, and 1 Day
3 Days
1 Month
5 Years, and 2 Months
7 Years, and 1 Day
1 Year, 1 Month, and 1 Day
700`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}