import re
regex = re.compile(r"^(?:(\d+)\sYears?)?,?\s?(?:and\s)?(?:(\d+)\sMonths?)?,?\s?(?:and\s)?(?:(\d+)\sDays?)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("3 Years, 1 Month, and 60 Days\n"
"2 Months, and 1 Day\n"
"3 Days\n"
"1 Month\n"
"5 Years, and 2 Months\n"
"7 Years, and 1 Day\n"
"1 Year, 1 Month, and 1 Day\n"
"700")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")