#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bNOT\h+index=("?)\w+(?:-\w+)*\1(*SKIP)(*FAIL)|index=("?)(?<my_indexes>\w+(?:-\w+)*)\2"
Local $sString = "tag=os index=linux index=windows NOT index=mac tag=db index="a_something-else" NOT index=solaris" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")