const regex = /\bNOT\h+index=("?)\w+(?:-\w+)*\1(*SKIP)(*FAIL)|index=("?)(?<my_indexes>\w+(?:-\w+)*)\2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bNOT\\h+index=("?)\\w+(?:-\\w+)*\\1(*SKIP)(*FAIL)|index=("?)(?<my_indexes>\\w+(?:-\\w+)*)\\2', 'gm')
const str = `tag=os index=linux index=windows NOT index=mac tag=db index="a_something-else" NOT index=solaris
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}