using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bNOT\h+index=(""?)\w+(?:-\w+)*\1(*SKIP)(*FAIL)|index=(""?)(?<my_indexes>\w+(?:-\w+)*)\2";
string input = @"tag=os index=linux index=windows NOT index=mac tag=db index=""a_something-else"" NOT index=solaris
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}