using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\s+\d+.*?\d{5}";
string input = @"
APPRAISAL REPORT
ABERDEEN SQUARE OFFICE BUILDING
110 W Market Street
Aberdeen, Washington 98520
PREPARED FOR:
Alyssa Barron
BANK OF THE PACIFIC
4124 Hannegan Road
Bellingham, Washington 98226
PREPARED BY:
Richard E. Cassinelli, MAI, AI-GRS
CASSINELLI VALUATION LLC
4804 NW Bethany Boulevard, Suite I-2
Portland, Oregon 97229
(503) 545-5217 / rich@cassval.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}