import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\s+\\d+.*?\\d{5}";
final String string = "\n\n\n\n\n\n\n\n\n\n\n\n"
+ " APPRAISAL REPORT\n"
+ " ABERDEEN SQUARE OFFICE BUILDING\n"
+ " 110 W Market Street\n"
+ " Aberdeen, Washington 98520\n\n\n\n"
+ " PREPARED FOR:\n"
+ " Alyssa Barron\n"
+ " BANK OF THE PACIFIC\n"
+ " 4124 Hannegan Road\n"
+ " Bellingham, Washington 98226\n\n\n\n"
+ " PREPARED BY:\n"
+ " Richard E. Cassinelli, MAI, AI-GRS\n"
+ " CASSINELLI VALUATION LLC\n"
+ " 4804 NW Bethany Boulevard, Suite I-2\n"
+ " Portland, Oregon 97229\n"
+ " (503) 545-5217 / rich@cassval.com\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}