# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\s+\d+.*?\d{5}"
test_str = ("\n\n\n\n\n\n\n\n\n\n\n\n"
" APPRAISAL REPORT\n"
" ABERDEEN SQUARE OFFICE BUILDING\n"
" 110 W Market Street\n"
" Aberdeen, Washington 98520\n\n\n\n"
" PREPARED FOR:\n"
" Alyssa Barron\n"
" BANK OF THE PACIFIC\n"
" 4124 Hannegan Road\n"
" Bellingham, Washington 98226\n\n\n\n"
" PREPARED BY:\n"
" Richard E. Cassinelli, MAI, AI-GRS\n"
" CASSINELLI VALUATION LLC\n"
" 4804 NW Bethany Boulevard, Suite I-2\n"
" Portland, Oregon 97229\n"
" (503) 545-5217 / rich@cassval.com\n\n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.