// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)\s+\d+.*?\d{5}").unwrap();
let string = "
APPRAISAL REPORT
ABERDEEN SQUARE OFFICE BUILDING
110 W Market Street
Aberdeen, Washington 98520
PREPARED FOR:
Alyssa Barron
BANK OF THE PACIFIC
4124 Hannegan Road
Bellingham, Washington 98226
PREPARED BY:
Richard E. Cassinelli, MAI, AI-GRS
CASSINELLI VALUATION LLC
4804 NW Bethany Boulevard, Suite I-2
Portland, Oregon 97229
(503) 545-5217 / rich@cassval.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}