import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*(?:href=\"([^\"]+?)\").*<\\/a>";
final String string = "<ul class=\"social\">\n"
+ " <li>\n"
+ " <a id=\"facebooklink\" href=\"\" style=\"display:none;\" class=\"facebook facebooklink\" title=\"Become a fan on Facebook\">Become a fan on Facebook<span></span></a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"https://twitter.com/StackOverflow\" id=\"twitterlink\" style=\"display:none;\" class=\"twitter twitterlink\" title=\"Follow us on Twitter\">Follow us on Twitter<span></span></a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a id=\"linkedinlink\" style=\"display:none;\" class=\"linkedin linkedinlink\" title=\"Follow us on LinkedIn\">Follow us on LinkedIn<span></span></a>\n"
+ " </li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}