re = /<a.*(?:href="([^"]+?)").*<\/a>/m
str = '<ul class="social">
<li>
<a id="facebooklink" href="" style="display:none;" class="facebook facebooklink" title="Become a fan on Facebook">Become a fan on Facebook<span></span></a>
</li>
<li>
<a href="https://twitter.com/StackOverflow" id="twitterlink" style="display:none;" class="twitter twitterlink" title="Follow us on Twitter">Follow us on Twitter<span></span></a>
</li>
<li>
<a id="linkedinlink" style="display:none;" class="linkedin linkedinlink" title="Follow us on LinkedIn">Follow us on LinkedIn<span></span></a>
</li>
</ul>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end