// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a.*(?:href="([^"]+?)").*<\/a>"#).unwrap();
let string = "<ul class=\"social\">
<li>
<a id=\"facebooklink\" href=\"\" style=\"display:none;\" class=\"facebook facebooklink\" title=\"Become a fan on Facebook\">Become a fan on Facebook<span></span></a>
</li>
<li>
<a href=\"https://twitter.com/StackOverflow\" id=\"twitterlink\" style=\"display:none;\" class=\"twitter twitterlink\" title=\"Follow us on Twitter\">Follow us on Twitter<span></span></a>
</li>
<li>
<a id=\"linkedinlink\" style=\"display:none;\" class=\"linkedin linkedinlink\" title=\"Follow us on LinkedIn\">Follow us on LinkedIn<span></span></a>
</li>
</ul>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}