# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a.*(?:href=\"([^\"]+?)\").*<\/a>"
test_str = ("<ul class=\"social\">\n"
" <li>\n"
" <a id=\"facebooklink\" href=\"\" style=\"display:none;\" class=\"facebook facebooklink\" title=\"Become a fan on Facebook\">Become a fan on Facebook<span></span></a>\n"
" </li>\n"
" <li>\n"
" <a href=\"https://twitter.com/StackOverflow\" id=\"twitterlink\" style=\"display:none;\" class=\"twitter twitterlink\" title=\"Follow us on Twitter\">Follow us on Twitter<span></span></a>\n"
" </li>\n"
" <li>\n"
" <a id=\"linkedinlink\" style=\"display:none;\" class=\"linkedin linkedinlink\" title=\"Follow us on LinkedIn\">Follow us on LinkedIn<span></span></a>\n"
" </li>\n"
"</ul>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.