use strict;
my $str = 'https://video.foxnews.com/v/video-embed.html?video_id=6203907215001
<iframe aria-label="More+Videos" src="//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=" marginwidth="0" marginheight="0" scrolling="no" width="466" height="263" frameborder="0"></iframe>
//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=
//video.foxnews.com/v/video-embed.html?video_id=6203907215001';
my $regex = qr~(https?:)?//video.foxnews.com/v/(video-embed.html\?video_id=)(?P<ID>[0-9]+)/?.*~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}