// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:)?//video.foxnews.com/v/(video-embed.html\?video_id=)(?P<ID>[0-9]+)/?.*").unwrap();
let string = "https://video.foxnews.com/v/video-embed.html?video_id=6203907215001
<iframe aria-label=\"More+Videos\" src=\"//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=\" marginwidth=\"0\" marginheight=\"0\" scrolling=\"no\" width=\"466\" height=\"263\" frameborder=\"0\"></iframe>
//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=
//video.foxnews.com/v/video-embed.html?video_id=6203907215001";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}