$re = '~(https?:)?//video.foxnews.com/v/(video-embed.html\?video_id=)(?P<ID>[0-9]+)/?.*~m';
$str = 'https://video.foxnews.com/v/video-embed.html?video_id=6203907215001
<iframe aria-label="More+Videos" src="//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=" marginwidth="0" marginheight="0" scrolling="no" width="466" height="263" frameborder="0"></iframe>
//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=
//video.foxnews.com/v/video-embed.html?video_id=6203907215001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);