import Foundation
let pattern = #"(https?:)?//video.foxnews.com/v/(video-embed.html\?video_id=)(?P<ID>[0-9]+)/?.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://video.foxnews.com/v/video-embed.html?video_id=6203907215001
<iframe aria-label="More+Videos" src="//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=" marginwidth="0" marginheight="0" scrolling="no" width="466" height="263" frameborder="0"></iframe>
//video.foxnews.com/v/video-embed.html?video_id=6203907215001&loc=qlobal-change.blogspot.com&ref=https%3A%2F%2Fqlobal-change.blogspot.com%2F2020%2F10%2Fdie-textnachrichten-eines.html&_xcf=
//video.foxnews.com/v/video-embed.html?video_id=6203907215001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)