using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\p{L}+)\b(?![\p{P}\p{S}])";
string substitution = @"\1:";
string input = @"Bajos
Ascensor
habs.:3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}