re = /(\p{L}+)\b(?![\p{P}\p{S}])/m
str = 'Bajos
Ascensor
habs.:3'
subst = '\\1:'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result