use strict;
my $str = 'Bajos
Ascensor
habs.:3';
my $regex = qr/(\p{L}+)\b(?![\p{P}\p{S}])/mp;
my $subst = '\\1:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";