$re = '/(\p{L}+)\b(?![\p{P}\p{S}])/m';
$str = 'Bajos
Ascensor
habs.:3';
$subst = "\1:";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;