using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\G(?!\A)|START_TAG)(?:(?!START_TAG|FOO).)*?)FOO(?=.*END_TAG)";
string substitution = @"$1<Replaced>";
string input = @"Text multiline, bla bla bla **FOO** text text text *START_TAG* text text text text **FOO** a lot of texts
**FOO** more text
*END_TAG*";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}