use strict;
my $str = 'Text multiline, bla bla bla **FOO** text text text *START_TAG* text text text text **FOO** a lot of texts
**FOO** more text
*END_TAG*';
my $regex = qr/((?:\G(?!\A)|START_TAG)(?:(?!START_TAG|FOO).)*?)FOO(?=.*END_TAG)/sp;
my $subst = '$1<Replaced>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";