using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^mock/(?P<message>[^/]+)/?$";
string input = @"mock/some_string
mock/some_string/
mock/some 1-2 strings here!/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}