$re = '/^mock/(?P<message>[^/]+)/?$/m';
$str = 'mock/some_string
mock/some_string/
mock/some 1-2 strings here!/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);