re = /^mock\/(?P<message>[^\/]+)\/?$/m
str = 'mock/some_string
mock/some_string/
mock/some 1-2 strings here!/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end