package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^mock/(?P<message>[^/]+)/?$`)
var str = `mock/some_string
mock/some_string/
mock/some 1-2 strings here!/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}