#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?m)^(.+?)\t"
Local $sString = "[SetID Size Position Area Weight]" & @CRLF & _
"Set01 100,20 200,300 20000 20" & @CRLF & _
"Set02 20,30 1000,200 600 5" & @CRLF & _
"Set03 40,10 1100,500 4000 60"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")