import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(.+?)\\t";
final String string = "[SetID Size Position Area Weight]\n"
+ "Set01 100,20 200,300 20000 20\n"
+ "Set02 20,30 1000,200 600 5\n"
+ "Set03 40,10 1100,500 4000 60";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}