using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(.+?)\t";
string input = @"[SetID Size Position Area Weight]
Set01 100,20 200,300 20000 20
Set02 20,30 1000,200 600 5
Set03 40,10 1100,500 4000 60";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}