// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(?m)^(.+?)\t").unwrap();
let string = "[SetID Size Position Area Weight]
Set01 100,20 200,300 20000 20
Set02 20,30 1000,200 600 5
Set03 40,10 1100,500 4000 60";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}